advertisement
from the Automation List department...
Yokogawa DCS to Modbus
Communications systems and equipment. topic
Posted by Matthew C. on 15 June, 2007 - 10:37 pm
I have a Yokogawa DCS system that is connecting to eleven (11) ABB variable frequency drives. We have successfully communicated to the drives, but communication is taking over 1 minute. We have configured the speed to be 19200 baud, but nothing we do seems to be fixing the issue. If anyone can help, I would greatly appreciate it. Thanks.


Posted by Zoran Cico on 19 June, 2007 - 1:36 am
Dear Matthew,

I don't know what type of Yokogawa DCS you are using, but if it is FCX (FCJ or FCN), then only 10 Communication channels can be used for optimal communication speed (only 10 OPEN POUs should be used).

You should try to disconnect one or two devices and see if the com. speed will be enhanced. If abovementioned will fix the problem, maybe you should try with ModbusTCP/485 converter (MOXA, BB) cause you will have only one Communication channel.

P.S. If one of reading or writing address are wrong it could significally decrease the com. speed.

Don't hesitate to write with more details (Topology, DCS type, Used POUs, Other Communication parameters (data bit, stop bit, parity)).

Best Regards,
Zoran Cico Bc.Sc.


Posted by Amin on 15 October, 2007 - 1:13 pm
Dear Zoran Cico Bc.Sc.,

Thank you for your attention.

I have Yokogawa DCS which control the Rorotk valve via Modbus communication.

But the speed for this communication is so low, that meens the commands from DCS will go to Pakscan Rotork with High Delay.

If you can help me for solving this problem, I will be very happy and thankful.

My Email: fka_eng_co @ hotmail. com
Best regards,

Amin


Posted by Shahid Waqas on 16 October, 2007 - 11:30 pm
You can use two alternate options:
1. Use OPC interface. You will require Pakscan OPC server, and OPC gateway (SIOS or GSGW).
2. Use Modbus over TCP/IP. You will require ALE111 card for the interface on the DCS side.

The second option is more appropriate, compared to OPC. Which Centum are you using (I assume CS3000 R3)?
--
Best Regards,
*Shahid Waqas*


Posted by Junaid on 21 November, 2007 - 1:48 am
Is there any one who can help me to solve a similar problem? I want to implement Modbus in Yokogawa Centum CS 3000 to communicate with field PLCs of Siemens S7300.

I shall appreciate this help.

Thanks.


Posted by Zoran Cico on 9 November, 2007 - 10:37 pm
Dear Amin,

Maybe you should give us some more details about which Modbus (RTU/ASCII/TCP) and which Yokogawa DCS (Stardom/Centum) you are using.

Of course, some of already tried communication parameters.

Best regards,
Zoran Cico


Posted by Amin on 2 December, 2007 - 6:59 pm
Dear Friends,
I will be very thankful if someone could inform me for connecting DCS Yokogawa (CS 3000) to operator station.

It is good to know that the Vnet network is Ok and FCS system is connected with Engineering station. Also I have connected engineering station (ES) with operation station through Ethernet. But I can not download my project to O.S.

Looking forward to your advice.

Best Regards
Amin


Posted by Russell Bull on 19 June, 2007 - 6:46 pm
Whenever I have issues with two pieces of equipment communicating via Modbus, the forst task is to find out which unit is 'not playing ball'. To do this I use a few tools - ADAM4561 USB->232/422/485 module and MODSCAN/MODSIM software from WinTech. I then 'sniff' the communications and see who is doing what. This alone will generally tell you what is going on.

You can use Modscan to simulate the master and Modsim to simulate the slave to verify both ends.

A common problem I've come across is the setting of the required response time. Some slaves can take some time to respond (some PLCs only respond every major cycle) whereas other slaves can respond almost immediately. Usually it is just a matter of settings on your DCS to slow things down a bit.


Posted by Nanda on 16 October, 2007 - 11:25 pm
As Russell said, trying using the Modscan or Modsim to simulate as master and try to communication with individual port and see the parameters are set right... if not set the correct parameters and see each port is working fine. If so... limit the maximum # to less than 10 and see if you could communicate better than 1 min. Try adding the ports so that you won't incure major delays.

Nanda


Posted by Steve Yates on 16 October, 2007 - 1:49 am
Which Yokogawa communication card do you have? We had a project a while back where a comms problem with multiple slaves connected via 2 wires to an ACM12 was solved by biasing the lines.

Steve
www.mtl-inst.com

Your use of this site is subject to the terms and conditions set forth under Legal Notices and the Privacy Policy. Please read those terms and conditions carefully. Subject to the rights expressly reserved to others under Legal Notices, the content of this site and the compilation thereof is © 1999-2014 Nerds in Control, LLC. All rights reserved.

Users of this site are benefiting from open source technologies, including PHP, MySQL and Apache. Be happy.


Fortune
Millihelen, adj:
The amount of beauty required to launch one ship.
Advertise here
Advertisement
our advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive